Requirements:


  • WINDOWS version Requires an IBM compatible, running Windows 3.1, Windows 95 or Windows 98, on a 386 higher.

  • Printer optional. Colour Printers are supported.